Нужно решение задачи в PascalABC и нарисованная блок-схема. Помогите пожалуйста. Условие задачи: В автоматизированной информационной системе содержатся анкетные данные сотрудников учреждения. В массиве V(8) содержатся года рожд...
Нужно решение задачи в PascalABC и нарисованная блок-схема. Помогите пожалуйста.
Условие задачи:
В автоматизированной информационной системе содержатся анкетные данные сотрудников учреждения.
В массиве V(8) содержатся года рождения сотрудников,
В массиве P(8) – сведения о поле,
В массиве S(8) – сведения о семейном положении.
Элемент массива V с номером N – год рождения сотрудника N,
Элемент массива P с номером N – сведения о поле сотрудника N,
Элемент массива S с номером N – сведения о семейном положении сотрудника N.
P(N)=0, сотрудник N женского пола
P(N)=1, сотрудник N мужского пола
S(N)=0, сотрудник N холост (не замужем)
S(N)=1, сотрудник N женат (замужем)
Определить:
Минимальный возраст среди замужних женщин
Ответ(ы) на вопрос:
Гость
var
i, j, n, min: integer;
v: array[1..8]of integer;
p: array[1..8]of integer;
s: array[1..8]of integer;
begin
min := 999;
for i := 1 to 8 do read(v[i]);
for i := 1 to 8 do read(p[i]);
for i := 1 to 8 do read(s[i]);
for i := 1 to 8 do if(p[i] = 0) and (s[i] = 1) and (v[i] < min) then min := v[i];
write(min);
end.
Пример:
Входные данные:
22 19 40 33 34 23 45 23
1 0 0 1 1 0 1 0
0 1 1 0 0 1 1 0
Выходные данные:
19
Не нашли ответ?
Похожие вопросы