Одна ручка стоит A Гривен и B Копеек! Написать программу которая определяет, сколько ручек можео купить за C Гривен и D копеек , а также сколько денег останеться!

Одна ручка стоит A Гривен и B Копеек! Написать программу которая определяет, сколько ручек можео купить за C Гривен и D копеек , а также сколько денег останеться!
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c,d,e,f,k,m:integer; begin writeln('A, B:'); readln(a,b); writeln('C, D:'); readln(c,d); e:=a*100+b; f:=c*100+d; k:=e div f; m:=e-k*f; writeln('k = ',k); writeln('Останется: ',m div 100,' гр ',m mod 100,' коп'); end. Пример: A, B: 28 15 C, D: 3 75 k = 7 Останется: 1 гр 90 коп
Не нашли ответ?
Ответить на вопрос
Похожие вопросы