Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 22: var i, k: integer; function F(x:integer):integer; begin F:=x*x*x+x*x; end; begin i := 20; readln(K); while (i больше...
Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 22:
var i, k: integer;
function F(x:integer):integer;
begin
F:=x*x*x+x*x;
end;
begin
i := 20;
readln(K);
while (i > 0) and (F(i) > K) do
i:=i-1;
writeln(i);
end.
Ответ(ы) на вопрос:
у тебя функция x^3+x^2 и перебор от 20 до 1, т.е. x^3+x^2 будет больше 22 при числах:
20, 19, 18, 17, 16, 15, 14, 13, 12, 11, 10, 9, 8, 7, 6, 5, 4, 3.
итого: 18 чисел
Не нашли ответ?
Похожие вопросы