Определите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.Алгоритмический языкБейсикПаскальалгначцел s, k s := 0 нц для k от 6 до 12 s := ...
Определите значение переменной s, полученное
в результате работы следующей программы. Текст программы приведён на трёх
языках программирования.
Алгоритмический язык
Бейсик
Паскаль
алг
нач
цел s, k
s := 0
нц для k от 6 до 12
s := s + 5
кц
вывод s
кон
DIM k, s AS INTEGER
s = 0
FOR k = 6 TO 12
s = s + 5
NEXT k
PRINT s
Vars,k: integer;
Begin
s := 0;
for k := 6 to 12 do
s := s + 5;
writeln(s);
End.
Ответ(ы) на вопрос:
Программа вычисляет сумму семи пятерок, т.е.
[latex]s=\Sigma_{k=6}^{12}5=5\times 7 = 35[/latex]
Ответ: будет получено и выведено число 35.
Не нашли ответ?
Похожие вопросы