PASCAL ABC NET ОТМЕЧУ КАК ЛУЧШИЙ ОТВЕТ!!! Задача 1. Вывести на экран натуральные числа от 1 до 9 в обратном порядке. Задача 2. Составить программу вычисления значения выражения y=1+1/2+1/3+... +1/20. {В данном случае целесообр...

PASCAL ABC NET ОТМЕЧУ КАК ЛУЧШИЙ ОТВЕТ!!! Задача 1. Вывести на экран натуральные числа от 1 до 9 в обратном порядке. Задача 2. Составить программу вычисления значения выражения y=1+1/2+1/3+... +1/20. {В данном случае целесообразно организовать цикл с параметром, изменяющимся от 1 до 20, то есть шаг изменения параметра равен +1. Обозначим: у - очередное значение суммы дробей; n - параметр цикла. Учитывая это, составим программу: }
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017 // Внимание! Если программа не работает, обновите версию! №1 begin   Range(9,1,-1).Println end. Результат 9 8 7 6 5 4 3 2 1 №2 begin   Writeln('S=',Range(1,20).Aggregate(0.0,(x,y)->x+1/y)) end. Результат S=3.59773965714368
Не нашли ответ?
Ответить на вопрос
Похожие вопросы