Pascal ABCЗадача 1составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат .Задача 2 сос...
Pascal ABC
Задача 1
составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат .
Задача 2
составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .
Ответ(ы) на вопрос:
Первая программа ,если не нравится исправлю
Добавил вторую
1.
Program ZADACHA;
Uses crt;
var a: integer;
Begin clrscr;
write('Введите целое число не равное нулю a = ');
readln(a);
writeln;
if a<0 then
Write('Число a отрицательное, результат = ', a*a)
else
Write('Число a положительное, результат = ', a/2);
End.
2.
Program CHETNOST;
Uses crt;
var a: integer;
Begin clrscr;
write('Введите целое число a = ');
readln(a);
writeln;
if (a mod 2) = 1 then
Write('Да')
else
Write('Нет');
End.
Не нашли ответ?
Похожие вопросы