Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. Все слова разделяются 1 пробелом и только русские буквы.

Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. Все слова разделяются 1 пробелом и только русские буквы.
Гость
Ответ(ы) на вопрос:
Гость
var   s: string;   i, n: integer;   a: set of char; begin   Writeln('Введите строку текста');   Readln(s);   n := 0;   a := ['А', 'а'];   for i := 1 to Length(s) do     if (s[i] = ' ') and (s[i - 1] in a) then n := n + 1;   if (s[i - 1] in a) then n := n + 1;   Writeln('Количество слов, оканчивающихся буквой "а", равно ', n) end. Тестовое решение: Введите строку текста А роза упала на лапу Азора Количество слов, оканчивающихся буквой "а", равно 4
Не нашли ответ?
Ответить на вопрос
Похожие вопросы