Паскаль АВС.NET Составить программу с записью Дата. Программа должна обеспечивать простейшие функции для работы с данными : увеличение/уменьшение на 1 день, ввод значений , вывод значений. Помогите пожалуйста.
Паскаль АВС.NET Составить программу с записью Дата. Программа должна обеспечивать простейшие функции для работы с данными : увеличение/уменьшение на 1 день, ввод значений , вывод значений. Помогите пожалуйста.
Ответ(ы) на вопрос:
uses
System;
var
d1, d2: DateTime;
s: string;
begin
Write('Введите дату в формате ДД.ММ.ГГГГ: ');
Readln(s);
d1 := DateTime.Parse(s); { получили дату }
d2 := d1.AddDays(-1);
Writeln('Предыдущий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
d2 := d1.AddDays(1);
Writeln('Следующий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
end.
Тестовое решение:
Введите дату в формате ДД.ММ.ГГГГ: 31.12.2014
Предыдущий день: 30.12.2014
Следующий день: 1.1.2015
Не нашли ответ?
Похожие вопросы