Паскаль Напишите программу, которая 10 раз запрашивает ввод целого числа. При завершении ввода на экран выводится сумма чисел, минимальное число, максимальное число.
Паскаль
Напишите программу, которая 10 раз запрашивает ввод целого числа. При завершении ввода на экран выводится сумма чисел, минимальное число, максимальное число.
Ответ(ы) на вопрос:
Program Lana132;
uses crt;
const n=10;
var
i,ch,max,min,sum:integer;
begin
writeln('*** Alphaeus is thinking... ***');
writeln('*** OK ***');
writeln(); writeln();
writeln('Программа запрашивает N чисел, находит их сумму, максимальное и минимальное число');
sum:=0;
write('Введите 1-e число: '); read(ch);
sum:=sum+ch;
max:=ch; min:=ch;
for i:=2 to n do
begin
write('Введите ',i,'-e число: '); read(ch);
sum:=sum+ch;
if maxch then min:=ch;
end;
writeln('Сумма всех чисел равна ',sum);
writeln('Максимальное число равно ',max);
writeln('Минимальное число равно ',min);
end.
Не нашли ответ?
Похожие вопросы