Паскаль. по древней легенде мудрец, который изобрел шахматы, потребовал столько зерен, чтобы заполнить ими шахматную доску. на каждую последующую клетку зерен должны были положить в 2 раза больше. 1 гр. = 15 зерен. сколько тонн...
Паскаль. по древней легенде мудрец, который изобрел шахматы, потребовал столько зерен, чтобы заполнить ими шахматную доску. на каждую последующую клетку зерен должны были положить в 2 раза больше. 1 гр. = 15 зерен. сколько тонн зерна получит мудрец? написать программу в паскаль
Ответ(ы) на вопрос:
Гость
Считаем, что на первую клетку положили 1 зерно. И всего 64 клетки.
1 вариант:
const n=64;
var s: real;
begin
s:=power(2,n-1)/15/1000/1000;
writeln;
writeln (s,' тонн зерна')
end.
2 вариант:
const n=64;
var s: real; i: byte;
begin
s:=1;
for i:=2 to n do
s:=s*2; // всего зерен
s:=s/15; // всего грамм
s:=s/1000; // всего килограмм
s:=s/1000; // всего тонн
writeln (s,' тонн зерна');
end.
---------------------------
614891469123.652 тонн зерна
Не нашли ответ?
Похожие вопросы