Паскаль. Составить программу, попадают ли ведённые данные в закрашенную область.
Паскаль. Составить программу, попадают ли ведённые данные в закрашенную область.
Ответ(ы) на вопрос:
Гость
var x,y : real;
begin
write('x = '); readln(x);
write('y = '); readln(y);
if (x*x+y*y<=1)and(x>=0)or(y>=-x/2-1)and(y<=x/2+1)and(x<=0)
then writeln('Да')
else writeln('Нет')
end.
Пример:
x = -1
y = 0.4
Да
Не нашли ответ?
Похожие вопросы