ПАСКАЛЬ, строка символовНапишите программу, которая:а) определяет, сколько раз встречается в строке символ 'A'б) заменяет символ 'А' символом ' * 'в) удаляет из строки символ 'В'Пожалуйста, помогите! :с
ПАСКАЛЬ, строка символов
Напишите программу, которая:
а) определяет, сколько раз встречается в строке символ 'A'
б) заменяет символ 'А' символом ' * '
в) удаляет из строки символ 'В'
Пожалуйста, помогите! :с
Ответ(ы) на вопрос:
а)Program z1;
Var S:string;
i,n,d:integer;
Begin
read(s);
d:=length(s);
n:=o;
For i:=1 to d do
If copy(S,i,1)='A' then
n:=n+1;
writeln(n );
End.
program proga;
var str:string;
i,counter,pos:integer;
k:char;
a:array[1..255] of char;
begin
k:='*';
counter:=0;
writeln('Введите строку');
readln(str);
for i:=1 to length(str) do begin
if str[i]='А' then begin
inc(counter);
Delete(str,i,1);
Insert(k,str,i);
end;
end;
writeln('Количество символов А ',counter);
for i:=1 to length(str) do begin
a[i]:=str[i];
if a[i]='В' then
a[i]:=' ';
write(a[i]);
end;
end.
Не нашли ответ?
Похожие вопросы