Паскаль.Известно, что первые два элемента массива равны a и b. А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы). Заполните массив...
Паскаль.Известно, что первые два элемента массива равны a и b. А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы). Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке.
Формат входных данных
Целые положительное число n (2
Целые числа a,b (-50 < a,b < 50)
Формат выходных данных
Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробел
Ответ(ы) на вопрос:
Гость
var n, a, b, i, j: integer;
ar: array[1..10000]of integer;
begin
read(n, a, b);
ar[1] := a;
ar[2] := b;
for i := 3 to n do
begin
for j := 1 to i - 1 do
begin
ar[i] := ar[i] + ar[j];
end;
ar[i] := ar[i] + i;
end;
for i := n downto 1 do write(ar[i],' ');
end.
Не нашли ответ?
Похожие вопросы