ПаскальНаписать программу,которая будет открывать txt файл,искать нужный текст и удалять его.После чего сохранит изменения.Нужно использовать цикл,т.к.поиск будет осуществляться много раз!txt  файл большой,с большим количеством...

Паскаль Написать программу,которая будет открывать txt файл,искать нужный текст и удалять его.После чего сохранит изменения. Нужно использовать цикл,т.к.поиск будет осуществляться много раз! txt  файл большой,с большим количеством перехода на новую строку.
Гость
Ответ(ы) на вопрос:
Гость
Только в среде Pascal.ABC.Net !!! Лучше писать результат не в тот же файл, а в другой: при составлении регулярных выражений без достаточного опыта можно легко ошибиться. uses   System.Text.RegularExpressions; const   CRLF = #13#10; var   s, sbig: string;   fin, fout: Text; begin   Assign(fin, 'MyIn.txt');   Reset(fin);   sbig := '';   while not Eof(fin) do   begin     Readln(fin, s);     sbig := sbig + s + CRLF   end;   Close(fin);   {пример - уладить подстроки, начиная с "http:" и до первого пробела,   причем внутри подстроки может встретиться переход на новую строчку.   Используется шаблон '\bhttp:\S+' - подробности: регулярные выражения}   sbig:=RegEx.Replace(sbig, '\bhttp:\S+', '', RegexOptions.Multiline);   Assign(fout, 'MyOut.txt');   Rewrite(fout);   Write(fout, sbig);   Close(fout);   Writeln('Конец работы'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы