ПОМОГИТЕ ИСПРАВИТЬ КОД, ЯЗЫК СИ Напишите программу поиска максимального из четы?
ПОМОГИТЕ ИСПРАВИТЬ КОД, ЯЗЫК СИ
Напишите программу поиска максимального из четы??ех чисел с использованием функции поиска большего из двух.
Ответ(ы) на вопрос:
Гость
#include <stdio.h>
int chislo(int a, int b) { if ( a > b ) return a; else return b;}
int main(){ int a,b,c,d;
printf("\n Óñëîâèå: Íàïèøèòå ïðîãðàììó ïîèñêà ìàêñèìàëüíîãî èç ÷åòûðåõ ÷èñåë ñ èñïîëüçîâàíèåì ôóíêöèè ïîèñêà áîëüøåãî èç äâóõ."); printf("\n\t Ââåäèòå 1 ÷èñëî -> "); scanf("%i",&a); printf("\n\t Ââåäèòå 2 ÷èñëî -> "); scanf("%i",&b); printf("\n\t Ââåäèòå 3 ÷èñëî -> "); scanf("%i",&c); printf("\n\t Ââåäèòå 4 ÷èñëî -> "); scanf("%i",&d);
printf ( "max=%i\n" , chislo(chislo(chislo(a,b),c),d));
return 0;}
printf("\n Óñëîâèå: Íàïèøèòå ïðîãðàììó ïîèñêà ìàêñèìàëüíîãî èç ÷åòûðåõ ÷èñåë ñ èñïîëüçîâàíèåì ôóíêöèè ïîèñêà áîëüøåãî èç äâóõ."); printf("\n\t Ââåäèòå 1 ÷èñëî -> "); scanf("%i",&a); printf("\n\t Ââåäèòå 2 ÷èñëî -> "); scanf("%i",&b); printf("\n\t Ââåäèòå 3 ÷èñëî -> "); scanf("%i",&c); printf("\n\t Ââåäèòå 4 ÷èñëî -> "); scanf("%i",&d);
printf ( "max=%i\n" , chislo(chislo(chislo(a,b),c),d));
return 0;}
Не нашли ответ?
Похожие вопросы