Помогите на Языке паскале пожалуйста срочно надо... Составить программу целого числа из десятичного в двоичную

Помогите на Языке паскале пожалуйста срочно надо... Составить программу целого числа из десятичного в двоичную
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017 // Внимание! Если программа не работает, обновите версию! begin   var n:int64;   Read(n);   var s:='';   var c:=Ord('0');   while n>0 do begin     s:=Chr(c+n mod 2)+s;     n:=n shr 1     end;   Writeln(s,'(2)') end. Пример 24523 101111111001011(2)
Гость
Var A:integer; B,C:String; Begin WriteLn('Введите целое число'); ReadLn(A); While A<>0 do Begin Str(A mod 2,C); B:=C + B; A:=A div 2; End; WriteLn(B); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы