Помогите !!написать программу которая для 3х значного числа если оно четное то возводит в квадрат ,а если не четное то находит сумму цифр
Помогите !!написать программу которая для 3х значного числа если оно четное то возводит в квадрат ,а если не четное то находит сумму цифр
Ответ(ы) на вопрос:
var
A: integer;
begin
readLn(A);
if (A mod 2 = 0) then
begin
A := sqr(A);
WriteLn('Квадрат введённого числа равен: ', A);
end else
begin
A := ((A mod 100) div 10) + (A mod 10) + (A div 100);
writeLn('Сумма цифр введённого числа равна: ', A);
end;
end.
Не нашли ответ?
Похожие вопросы