Помогите написать программу на Pascal, условие: даны три действительных числа. возвести в квадрат те из них, значения которых неотрицательны.
Помогите написать программу на Pascal, условие: даны три действительных числа. возвести в квадрат те из них, значения которых неотрицательны.
Ответ(ы) на вопрос:
Гость
Var a,b,c: real;
Begin
Readln(a,b,c);
if (a>0) then a:=a*a;
if (b>0) then b:=b*b;
if (c>0) then c:=c*c;
Writeln(a,' ',b,' ',c);
Readln(a);
end.
Не нашли ответ?
Похожие вопросы