Помогите написать программу на паскале абс цикл с постусловием Дано целое число N ( больше 1). Вывести наименьшее из целых чисел K, для которых сумма 1 + 2 + … + K будет больше или равна N, и саму эту сумму.
Помогите написать программу на паскале абс
цикл с постусловием
Дано целое число N (> 1). Вывести наименьшее из целых чисел K, для которых сумма
1 + 2 + … + K будет больше или равна N, и саму эту сумму.
Ответ(ы) на вопрос:
Гость
var n,k,summ:integer;
begin
write('Введи число N: ');
readln(n);
repeat begin
k:=k+1;
summ:=summ+k;
end;
until summ>=n;
writeln('K=',k,', 1+..+',k,'=',summ,', ',summ,'>=',N);
end.
Не нашли ответ?
Похожие вопросы