Помогите написать программу на паскале!!! Выбрать из текста слова в которых первая буква совпадает с последней, слова в тексте разделены пробелами

Помогите написать программу на паскале!!! Выбрать из текста слова в которых первая буква совпадает с последней, слова в тексте разделены пробелами
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016 begin   var s:=ReadlnString('Введите текст:');   Writeln('Слова, в которых совпадают первая и последняя буквы:');   s.ToWords.Where(x->x[1]=x[x.Length]).Println(NewLine) end. Тестовое решение Введите текст: космос азбука     баобаб  импульс озеро  довод  конец Слова, в которых совпадают первая и последняя буквы: азбука баобаб озеро довод
Гость
//Free Pascal 2.6.4 uses   strutils; var   s, t: string;   i: integer; begin   write('Введите текст: ');   readln(s);   writeln('Найденные слова: ');   for i := 1 to WordCount(s, StdWordDelims) do   begin     t := ExtractWord(i, s, StdWordDelims);     if t[1] = t[length(t)] then writeln(t);   end;   readln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы