Помогите написать программу паскаль, которая формирует массив, элементами которого являются цифры заданного натурального числа.
Помогите написать программу паскаль, которая формирует массив, элементами которого являются цифры заданного натурального числа.
Ответ(ы) на вопрос:
var
a: array of byte; //char?
b, d: integer;
begin
readln(b);
SetLength(a, length(IntToStr(b)));
for d := 0 to length(a) - 1 do
begin
a[d] := b mod 10;
b := b div 10;
end;
for d := 0 to (length(a) - 1) do
write(a[d], ' ');
end.
Не нашли ответ?
Похожие вопросы