Помогите написать программу в Pascal, которая вычисляет среднюю оценку за неделю (с помощью массивов)

Помогите написать программу в Pascal, которая вычисляет среднюю оценку за неделю (с помощью массивов)
Гость
Ответ(ы) на вопрос:
Гость
//PascalABC.Net begin var a: array of integer; setLength (a, readinteger('Введите кол-во учеников: ')); for var i:=0 to length(a)-1 do a[i]:=readinteger ('Введите оценку ученика: '); write ('Средняя оценка: ', a.Average); end.
Гость
Program n1; const n=12; var a: array[1..n] of integer; i,sum: integer; begin randomize; sum:=0; write('оценки за неделю: '); for i:=1 to n do begin a[i]:=random(4)+2; write(a[i],' '); end; writeln; for i:=1 to n do sum:=sum+a[i]; writeln('среднее арифмитическое: ',sum/n); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы