Помогите написать программу в С++, пожалуйста! Дан номер некоторого года (целое положительное число больше 1000). Определить соответствующий ему номер столетия, учитывая, что, к примеру, началом 20 столетия был 1901 год.

Помогите написать программу в С++, пожалуйста! Дан номер некоторого года (целое положительное число>1000). Определить соответствующий ему номер столетия, учитывая, что, к примеру, началом 20 столетия был 1901 год.
Гость
Ответ(ы) на вопрос:
Гость
#include using namespace std; int main() {     int Leto;     cout <<"Leto > 1000"<<"\n";     cout << "Leto = ", cin >> Leto;     cout << "Stoletie = "<< Leto/100+(Leto%100>0?1:0)<<"\n";     system("Pause");     return 0; }
Гость
#include using namespace std; int main() {     int year;     cout << "Год (>1000) = ";     cin >> year;     cout << "Столетие = "<< (year-1)/100+1 <<"\n";     system("Pause");     return 0; } Пример: Год (>1000) = 1501 Столетие = 16
Не нашли ответ?
Ответить на вопрос
Похожие вопросы