Помогите написать программу в С++,пожалуйста. ↓↓↓↓Дан целочисленный массив из 40 элементов. Элементы массива могут принимать произвольные целые значения.Напишите программу,которая находит и выводит сумму наибольшей возрастающей...
Помогите написать программу в С++,пожалуйста. ↓↓↓↓
Дан целочисленный массив из 40 элементов. Элементы массива могут принимать произвольные целые значения.Напишите программу,которая находит и выводит сумму наибольшей возрастающей последовательности подряд идущих элементов.
Ответ(ы) на вопрос:
Гость
#include
using namespace std;
const int N = 40;
int main()
{
int m[N + 1];
int k,max, maxi;
for (int i = 0; i <= N; i++)
{
cin >>m[i];
}
int i = 0;
k = 0;
max = 0;
for (int j = 0; j < N; j++){
i = j;
while(m[i] max)
{
max = k;
maxi = i;
}
i = 0;
k = 0;
}
int s = 0;
for (int i = maxi; i <= maxi + max; i++)
s+= m[i];
cout << s;
return 0;
}
Не нашли ответ?
Похожие вопросы