Помогите написать программу , задача №607(a) (Delphi)
Помогите написать программу , задача №607(a) (Delphi)
Ответ(ы) на вопрос:
program Matrix;
var
ma: array [1..5] of array [1..7] of integer;
i, j: integer;
begin
//Получение данных
for j:=1 to 7 do
Read(ma[1,j]);
Readln;
//Подсчет остальной части матрицы
for i:=2 to 5 do
for j:=1 to 7 do
ma[i,j]:=ma[i-1,j]*ma[1,j];
//Вывод
for i:=1 to 5 do
begin
for j:=1 to 7 do
write(ma[i,j],' ');
writeln;
end;
end.
Не нашли ответ?
Похожие вопросы