Помогите написать программуопридиление цыфр в натуральном числе n
Помогите написать программу
опридиление цыфр в натуральном числе n
Ответ(ы) на вопрос:
Писал на C# Вроде всё понятно) Что не понятно спрашивай) Если нужно, могу сбросить готовую программу))
Console.WriteLine("Введите число");
int n = Convert.ToInt16(Console.ReadLine());//Вводим число
int m = n; // это просто для красоты результата
int i = 0; //задаём начальное количество цифер в числе
for (int nn = n; n > 0; n /= 10, i++) ; //Сам наш цикл который выщитывает сколько цифер в числе.
Console.WriteLine("----------------");
Console.WriteLine("Количество натуральных цифер в числе "+ m +" = "+ i);
Console.ReadLine();
Не нашли ответ?
Похожие вопросы