ПОМОГИТЕ ПЛИЗ!!!! 1)Составить программу, определяющую на какую букву заканчивается предложение. 2) Определить длину 2 слова в предложении
ПОМОГИТЕ ПЛИЗ!!!!
1)Составить программу, определяющую на какую букву заканчивается предложение.
2) Определить длину 2 слова в предложении
Ответ(ы) на вопрос:
var s: string;
k: integer;
begin
write('строка: '); readln(s);
writeln('строка заканчивается на букву ','"',s[length(s)],'"');
k:=pos(' ',s);
if k=0 then
begin
writeln('в строке одно слово');
exit;
end;
delete(s,1,k);
k:=pos(' ',s);
write('длина второго слова: ');
if k=0 then writeln(length(s))
else writeln(k-1);
end.
строка: это строка для проверки
строка заканчивается на букву "и"
длина второго слова: 6
Не нашли ответ?
Похожие вопросы