Помогите пож в С++ Напишите программу, которая выполняет реверс массива: меняет м?
Помогите пож в С++
Напишите программу, которая выполняет реверс массива: меняет м??стами первый и последний элементы, второй и предпоследний и т.д.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.
Ответ(ы) на вопрос:
Гость
#include <iostream>
using namespace std;
int main()
{
int n,i;
cin >> n;
int a[n];
for (i = 1; i <= n; i++)
cin >> a[i];
for (i = n; i > 0; i--)
cout << a[i] << " ";
}
Не нашли ответ?
Похожие вопросы