Помогите, пожалуйста!!! 2) Требовалось написать программу, которая вводит с клавиа

Помогите, пожалуйста!!! 2) Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно. Вот она: var x,y: real; begin readln(x,y); if y >= -1 then if y <= sin(x) then if y >= x-1 then write('принадлежит') else write('не принадлежит') end. а) приведите пример таких чисел x, y, при которых программа неверно решает поставленную задачу; б) укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы; это можно сделать несколькими способами, поэтому можно указать любой способ доработки исходной программы.
Гость
Ответ(ы) на вопрос:
Не нашли ответ?
Ответить на вопрос
Похожие вопросы