Помогите,пожалуйста,написать программу в PascalABC спасибо!

Помогите,пожалуйста,написать программу в PascalABC спасибо!
Гость
Ответ(ы) на вопрос:
Гость
Программа написана с учетом того, что символ "." в строке обязательно есть (т.е. без контроля ввода). var s,s1:string; i:integer; begin writeln('Введите строку:'); readln(s); s1:=''; i:=length(s); while s[i]<>'.' do  begin  s1:=s[i]+s1;  i:=i-1;  end; writeln('Расширение файла - ',s1); end. Пример: Введите строку: С:\учёба\математика\ГИА\Расписание.txt Расширение файла - txt
Не нашли ответ?
Ответить на вопрос
Похожие вопросы