Помогите пожалуйста с домашней работой. Напишите программу, которая вычисляет с?

Помогите пожалуйста с домашней работой. Напишите программу, которая вычисляет с??мму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Гость
Ответ(ы) на вопрос:
Гость
A) var s, i, n :integer; begin s:=0; readln(n); for i:= 1 to n do s:=s+i; writeln(s); end. б) var s, i, n :integer; begin s:=0; readln(n); for i:= 1 to n do s:=s+(i*i); writeln(s); end. в) var s, i, n :integer; begin s:=0; readln(n); for i:= 1 to n do begin if (i mod 2 = 0) then s:=s+i; end; writeln(s); end. г) var s, i :integer; begin s:=0; for i:= 10 to 99 do s:=s+i; writeln(s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы