Помогите пожалуйста! Написать программу , которая вычислит отдельные суммы четных и нечетных чисел натурального ряда и их произведения

Помогите пожалуйста! Написать программу , которая вычислит отдельные суммы четных и нечетных чисел натурального ряда и их произведения
Гость
Ответ(ы) на вопрос:
Гость
Const N = 7; Var A:array[1..N]of integer; i:integer; S,Sn,P,Pn:real; Begin S:=0; Sn:=0; P:=1; Pn:=1; For i:= 1 to N do Begin A[i]:=random(7)+1; Write(A[i],' '); if A[i] mod 2 = 0 then Begin S:=S+A[i]; P:=P*A[i]; End else Begin Sn:=Sn+A[i]; Pn:=Pn*A[i]; End End; WriteLn; WriteLn('Сумма чётных элементов =',S); WriteLn('Произведение чётных элементов =',P); WriteLn('Сумма НЕчётных элементов =',Sn); WriteLn('Произведение НЕчётных элементов =',Pn); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы