Помогите, пожалуйста написать программу на паскаль Дано натуральное число. Вычислить количество цифр, являющихся степенями тройки (1,3,9).

Помогите, пожалуйста написать программу на паскаль Дано натуральное число. Вычислить количество цифр, являющихся степенями тройки (1,3,9).
Гость
Ответ(ы) на вопрос:
Гость
var n, digit, ans : integer; begin     read(n);     ans := 0;     while (n > 0) do begin         digit := n mod 10;         if ((digit = 1) or (digit = 3) or (digit = 9)) then             ans := ans + 1;         n := n div 10;     end;     writeln(ans); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы