Помогите пожалуйста написать программу на Паскале!! Найти наибольшую цифру числа и ее порядковый номер и найти сумму наибольшей и наименьшей цифры. Помогите пожалуйста

Помогите пожалуйста написать программу на Паскале!! Найти наибольшую цифру числа и ее порядковый номер и найти сумму наибольшей и наименьшей цифры. Помогите пожалуйста
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017 // Внимание! Если программа не работает, обновите версию! begin   var s:=ReadlnString('n=');   var p:=s.ToCharArray.IndexMax;   Writeln('Максимальная цифра ',s[p+1],' имеет номер ',p+1);   Writeln('Сумма наибольшей и наименьшей цифр равна ',     s.Min.ToDigit+s.Max.ToDigit) end. Пример n= 145384 Максимальная цифра 8 имеет номер 5 Сумма наибольшей и наименьшей цифр равна 9
Не нашли ответ?
Ответить на вопрос
Похожие вопросы