Помогите пожалуйста написать программу на паскале : Пользователь вводит зарплату в рублях,например 20000,вычесть из этой зарплаты 13 %,результат вывести на экран
Помогите пожалуйста написать программу на паскале : Пользователь вводит зарплату в рублях,например 20000,вычесть из этой зарплаты 13 %,результат вывести на экран
Ответ(ы) на вопрос:
Это задача на вычисление суммы после уплаты налога.
Если s0 - исходная сумма, а р - процент налога, то ищется s=s0-s0*p/100.
Окончательная формула: s=s0(1-p/100)
const
p=13; { налог в процентах }
var
s0,s:real;
begin
Write('Введите сумму '); Read(s0);
s:=s0*(1-p/100);
{ а теперь округлим сумму до копеек, т.е. до 0.01 }
s:=Int(100*(s+0.005))/100;
Writeln('Сумма после вычета налога ',p,'% составит ',s:0:2)
end.
Тестовое решение:
Введите сумму 2000
Сумма после вычета налога 13% составит 1740.00
Замечание. При целочисленной зарплате и целочисленном проценте налога оператор s:=Int(100*(s+0.005))/100; не нужен, поскольку в дробной части всегда будет не больше двух знаков. Но, поскольку о сумме зарплаты ничего не говорится, а дано только конкретное значение, которое понято как тестовый пример, было предложено решение с округлением.
Не нашли ответ?
Похожие вопросы