Помогите, пожалуйста, написать программу в Паскаль Если дано трехзначное число, например 123 его можно представить в виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу, которая, получая от пользователя т...
Помогите, пожалуйста, написать программу в Паскаль
Если дано трехзначное число, например 123 его можно представить в виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу, которая, получая от пользователя трехзначное число, будет определять из каких цифр оно состоит и выводить их через пробел (например, 1_2_3).
Ответ(ы) на вопрос:
Гость
var a,b,c,d,e:integer;
begin
writeln('Введите число');
readln(a);
b:= a div 10;
e:=a mod 10;
d:=b mod 10;
c:=a div 100;
writeln(c,' ',d,' ',e);
end.
Не нашли ответ?
Похожие вопросы