Помогите пожалуйста написать программу: заполнить таблицу значений функции y=sqrt((1/2*x-1)+2) с шагом 0,1. Значения аргумента берутся из [0;3,8]. Предстоит продумать вопрос вывода результата.

Помогите пожалуйста написать программу: заполнить таблицу значений функции y=sqrt((1/2*x-1)+2) с шагом 0,1. Значения аргумента берутся из [0;3,8]. Предстоит продумать вопрос вывода результата.
Гость
Ответ(ы) на вопрос:
Гость
uses Crt; var   x,y:real; begin   ClrScr;   x:=0;   while x<=3.8 do   begin      y:=sqrt((1/2*x-1)+2);      Writeln(x:3:1,'  ',y:10:8);      x:=x+0.1   end;   ReadKey end. Результат выполнения программы: 0.0  1.00000000 0.1  1.02469508 0.2  1.04880885 0.3  1.07238053 0.4  1.09544512 0.5  1.11803399 0.6  1.14017543 0.7  1.16189500 0.8  1.18321596 0.9  1.20415946 1.0  1.22474487 1.1  1.24498996 1.2  1.26491106 1.3  1.28452326 1.4  1.30384048 1.5  1.32287566 1.6  1.34164079 1.7  1.36014705 1.8  1.37840488 1.9  1.39642400 2.0  1.41421356 2.1  1.43178211 2.2  1.44913767 2.3  1.46628783 2.4  1.48323970 2.5  1.50000000 2.6  1.51657509 2.7  1.53297097 2.8  1.54919334 2.9  1.56524758 3.0  1.58113883 3.1  1.59687194 3.2  1.61245155 3.3  1.62788206 3.4  1.64316767 3.5  1.65831240 3.6  1.67332005 3.7  1.68819430 3.8  1.70293864
Не нашли ответ?
Ответить на вопрос
Похожие вопросы