Помогите пожалуйста! Нужно вытянуть оценку!!! Напишите процедуру ввода N элементов массива из файла. Отсортируйте по невозрастанию методом простого обмена. (Паскаль)

Помогите пожалуйста! Нужно вытянуть оценку!!! Напишите процедуру ввода N элементов массива из файла. Отсортируйте по невозрастанию методом простого обмена. (Паскаль)
Гость
Ответ(ы) на вопрос:
Гость
var  i,j,n,k: integer;   a: array [1..100] of integer; begin assign (input,'input.txt'); reset(input); assign(output,'output.txt'); rewrite(output); readln (n); for i:=1 to n do read(a[i]); for i:=1 to n do  for j:=1 to n-i do  if a[j+1]>a[j] then begin k:=a[j]; a[j]:=a[j+1]; a[j+1]:=k; end; for i:=1 to n do write (a[i],' '); end. Входные данные писать в файл input.txt в формате: n a[i] a[i+1] a[i+2]...a[n].
Не нашли ответ?
Ответить на вопрос
Похожие вопросы