Помогите, пожалуйста, с написанием программы! Pascal abc "Составьте программу вычисления суммы тех элементов одномерного массива А(N), что одновременно встречаются в массивах B(N) и C(N)"

Помогите, пожалуйста, с написанием программы! Pascal abc "Составьте программу вычисления суммы тех элементов одномерного массива А(N), что одновременно встречаются в массивах B(N) и C(N)"
Гость
Ответ(ы) на вопрос:
Гость
const   n = 20; { размер массивов }   p=0; { минимальное значение элемента }   q=15; { максимальное значение элемента } type   V=array[1..n] of integer; procedure VInit(var a:V; s:string); { процедура заполняет элементы массива a   случайными значениями из интервала [p;q].   Элементы сформированного массива выводятся   с заголовком, в который добавляется значение s } var   i,kol:integer; begin    kol:=q-p+1;   Writeln('Элементы массива ',s);   for i:=1 to n do   begin a[i]:=Random(kol)+p; Write(a[i],' ') end;   Writeln end; procedure SortBubble(var a:V); { сортировка методом пузырька } var   i,j,t:integer; begin   for i := 1 to n-1 do     for j := 1 to n-i do       if a[j] > a[j+1] then       begin t := a[j]; a[j] := a[j+1]; a[j+1] := t end end; procedure VOut(var a:V;s:string); { Элементы массива a выводятся с заголовком s } var   i:integer; begin    Writeln(s);   for i:=1 to n do Write(a[i],' ');   Writeln end; function BinSearch(var a:V;key:integer):boolean; { двоичный поиск элемента со значением key в массиве a   Возвращает true, если элемент найден и false, если нет } var   li,ri,mi:integer; begin   li:=1; ri:=n;   while li
Не нашли ответ?
Ответить на вопрос
Похожие вопросы