Помогите пожалуйста с программой..(в Паскале)Составить программу табулирования функции заданной рекурентной формулой. f(0)=1;  f(1)=2;  f(n+2)=2*f(n+1)-n

Помогите пожалуйста с программой..(в Паскале) Составить программу табулирования функции заданной рекурентной формулой.  f(0)=1;  f(1)=2;  f(n+2)=2*f(n+1)-n
Гость
Ответ(ы) на вопрос:
Гость
function f(n:integer): integer; begin   if n=0 then f := 1   else if n=1 then f := 2   else f := 2*f(n-1)-n+2; end; var n: integer; begin    writeln('n':5, 'f(n)':10);   for n := 0 to 20 do     writeln(n:5, f(n):10);   end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы