Помогите пожалуйста с языком паскаля, срочно надо. 1) написать программу, которая удаляет из строки заданное количество символов. 2) написать программу, которая выставляет в строку подстроку. 3) написать программу подсчитывающу...

Помогите пожалуйста с языком паскаля, срочно надо. 1) написать программу, которая удаляет из строки заданное количество символов. 2) написать программу, которая выставляет в строку подстроку. 3) написать программу подсчитывающую количество знаков $ в вводимой строке.
Гость
Ответ(ы) на вопрос:
Гость
var strok: string; n,k: integer; begin writeln('введите строку'); readln(strok); writeln('с какого по счёту символа начать удаление?'); readln(n); writeln('сколько символов удалить?'); readln(k); delete(strok, n, k); writeln(strok); end. это первая var strok,strok2: string; n: integer; begin writeln('введите строку'); readln(strok); writeln('с какого символа по счёту вставить строку?'); readln(n); writeln('какую строку вставить?'); readln(strok2); insert(strok2 ,strok, n); writeln(strok); end. это вторая, а третья в коментах, иначе не влезет
Не нашли ответ?
Ответить на вопрос
Похожие вопросы