Помогите Пожалуйста!!!! Составить программу определяющее двухзначное число. Составить программу определяющее произведение от 1 до n.
Помогите Пожалуйста!!!!
Составить программу определяющее двухзначное число.
Составить программу определяющее произведение от 1 до n.
Ответ(ы) на вопрос:
Гость
Program programma;
Uses crt;
var a,k: integer;
begin
write ('Введите число а = ');
readln(a);
while abs(a)>0 do
begin
a:=a div 10;
k:=k+1;
end;
if k=2 then writeln('Число двузначное')
else
writeln('Число не является двузначным')
End.
Program programma;
Uses crt;
var n,p,i: integer;
Begin clrscr;
write('Введите число N = ');
readln(n);
p:=1;
write('P=');
for i:=1 to n-1 do
begin
p:=p*i;
write(i,'*');
end;
p:=p*n;
write(n,'=', p);
End.
Не нашли ответ?
Похожие вопросы