Помогите пожалуйста!! ) составить программу в "Pascal abc"!!) Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h. Результат представить в виде таблицы, первый столбец которой — значения аргумента...

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!) Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h. Результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"
Гость
Ответ(ы) на вопрос:
Гость
var   a,b,h,x,y:real; begin   writeln('Введите начальное значение, шаг, конечное значение');   readln(a,h,b);   x:=a;   while x<=b do begin     y:=0.5/tan(x/4)+4;     writeln(x:7:3,y:10:5);     x:=x+h   end end. Тестовое решение: Введите начальное значение, шаг, конечное значение -5 0.5 5  -5.000   3.83386  -4.500   3.76106  -4.000   3.67895  -3.500   3.58244  -3.000   3.46329  -2.500   3.30698  -2.000   3.08476  -1.500   2.72976  -1.000   2.04184  -0.500   0.02086   0.000  Infinity   0.500   7.97914   1.000   5.95816   1.500   5.27024   2.000   4.91524   2.500   4.69302   3.000   4.53671   3.500   4.41756   4.000   4.32105   4.500   4.23894   5.000   4.16614
Не нашли ответ?
Ответить на вопрос
Похожие вопросы