ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран. Если первое число пол...
ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.
Ответ(ы) на вопрос:
Program A1;
var
N,M,K:real;
Begin
writeln('Введите числа N и M');
readln(N,M);
If N>100 and M>100 then
N:=N-1;
M:=M-1;
writeln(M,N);
If N>0 and M<0 then
N:=N/2;
M:=M/2;
writeln(N,M)
Else
K:=0;
K:=(M+N)/2;
writeln(K);
End.
Не нашли ответ?
Похожие вопросы