Помогите пожалуйста! Составьте программу для вычисления значения выражения x в степени n + y в степени m. Значения x,y,n,m больше 0 вводятся с клавиатуры. Примечание: чтобы возвести число в n-ную степень, надо его умножить сам...

Помогите пожалуйста! Составьте программу для вычисления значения выражения x в степени n + y в степени m. Значения x,y,n,m >0 вводятся с клавиатуры. Примечание: чтобы возвести число в n-ную степень, надо его умножить само на себя n раз.
Гость
Ответ(ы) на вопрос:
Гость
begin var x, y, n, m: integer; Readln(x, y, n, m); Assert((x > 0) and (y > 0) and (n > 0) and (m > 0)); var upstep: integer := n + y; for var i := 2 to m do upstep *= (n + y); var lowstep := x; for var j := 2 to upstep do lowstep *= x; Writeln(lowstep); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы