Помогите пожалуйста, язык программирования паскаль. 1)Дана последовательность чисел, оканчивающихся 0. Определите сумму всех двузначных положительных и четных чисел. 2)дана последовательность из n чисел. Сколько чисел этой посл...
Помогите пожалуйста, язык программирования паскаль.
1)Дана последовательность чисел, оканчивающихся 0. Определите сумму всех двузначных положительных и четных чисел.
2)дана последовательность из n чисел. Сколько чисел этой последовательности являются двузначными, у которых последняя цифра 3.
Ответ(ы) на вопрос:
Гость
1)program qq;
const N=(количество чисел в массиве);
var A:array[1..N] of integer;
i, S:integer;
begin
for i:=1 to N do readln(A[i]);
S=0;
for i:=0 to N do
if (A[i]>9) and (A[i]<100) and (A[i]mod2=0) then S:=S+A[i];
writeln(s);
end.
2) program qq1;
const N=(количество чисел в массиве);
var A:array[1..N] of integer;
i, k:integer;
begin
for i:=1 to N do readln(A[i]);
k:=0;
for i:=0 to N do
if (A[i]mod10=3) and (A[i]<100) and (A[i]>9) then k:=k+1;
writeln(k);
end.
Не нашли ответ?
Похожие вопросы