Помогите пожалуйста!!Буду очень сильно благодарен!! На языке PascalABC.Net: 1)Определить значение z = max (a, 2b) • max (2a-b, b),где max (x, y) есть максимальное из чисел х, у. При решении задачи определить и использовать функ...

Помогите пожалуйста!!Буду очень сильно благодарен!! На языке PascalABC.Net: 1)Определить значение z = max (a, 2b) • max (2a-b, b),где max (x, y) есть максимальное из чисел х, у. При решении задачи определить и использовать функцию max.Выполнить отладку программы с заходом в каждую из подпрограмм. 2)Найти сумму четных элементов массива целых чисел. Массив должен вводится во время работы программы.Выполнить отладку программы с заходом в каждую из подпрограмм. 3)Написать программу, которая вводит двумерный массив А(N,M) и заменяет все отрицательные элементы на 0.
Гость
Ответ(ы) на вопрос:
Гость
//PascalABC.NET 3.1 сборка 1239 1) хотя не понятно зачем изобретать велосипед function max(a, b: integer): integer; begin     max := a;     if b > a then         max := b; end; begin     var a:=ReadInteger('a =');     var b:=ReadInteger('b =');     writeln(max(a, 2 * b) * max(2 * a - b, b)); end. 2) const     handfree = false; begin     var a:= new integer[ReadInteger('n =')];     if handfree then         a := ArrRandomInteger(a.Length, -50, 50)     else         a := ReadArrInteger(a.Length);          writeln('Array:');     a.Println;     writeln('Sum of odds by value = ', a.Where(x -> x mod 2 = 0).Sum);     writeln('Sum of odds by position = ', a.Slice(0, 2).Sum); end. 3) const     n = 5;     m = 6;     handsfree = false; begin     var a := new integer[n, m];     writeln('Данные матрицы:');     for var i := a.GetLowerBound(0) to a.GetUpperBound(0) do     begin         for var j := a.GetLowerBound(1) to a.GetUpperBound(1) do             if handsfree then begin                 a[i, j] := random(-50, 50);                 write(a[i, j]:4, ' ')             end             else                 read(a[i, j]);         writeln;     end;          writeln('Вывод:');     for var i := a.GetLowerBound(0) to a.GetUpperBound(0) do     begin         for var j := a.GetLowerBound(1) to a.GetUpperBound(1) do         begin             if a[i, j] < 0 then a[i, j] := 0;             write(a[i, j]:4, ' ');         end;         writeln;     end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы