ПОМОГИТЕ ПОЖАЛУЙСТА/ИВТ 9 КЛАСС ДЕЛФИ / ПАСКАЛЬ/ 50 БАЛЛОВ Напишите программу, которая по данному натуральному числу n выводит все его простые натуральные делители с учетом кратности. Время работы программы должно быть пропорци...
ПОМОГИТЕ ПОЖАЛУЙСТА/ИВТ 9 КЛАСС ДЕЛФИ / ПАСКАЛЬ/ 50 БАЛЛОВ
Напишите программу, которая по данному натуральному числу n выводит все его простые натуральные делители с учетом кратности. Время работы программы должно быть пропорционально корню из n.
Входные данные
Программа получает на вход одно число n<2^31.
Выходные данные
Программа должна вывести все простые натуральные делители числа n с учетом кратности в порядке неубывания.
Примеры
входные данные
6
выходные данные
2 3
Ответ(ы) на вопрос:
Гость
var
n,d,k:int64;
begin
read(n);
d := 2; k := 4;
while k <= n do
begin
while n mod d = 0 do
begin
write(d,' ');
n := n div d;
end;
k := k + 2*d + 1;
d := d + 1;
end;
if n > 1 then write(n);
end.
Не нашли ответ?
Похожие вопросы