Помогите решить, сколько сможете!!!(Паскаль) 1)Дано целое четырехзначное число. Выяснить, является ли оно палиндромом, то есть таким числом, десятичная запись которого читается одинаково слева направо и справа налево. 2)Дано це...
Помогите решить, сколько сможете!!!(Паскаль) 1)Дано целое четырехзначное число. Выяснить, является ли оно палиндромом, то есть таким числом,
десятичная запись которого читается одинаково слева направо и справа налево. 2)Дано целое трехзначное число. Определить, равен ли квадрат этого числа сумме кубов его цифр. 3)Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые 4)Дано целое четырехзначное число. Определить, равна ли сумма двух его первых цифр сумме двух его последних цифр. 5) Даны три целых числа. Определить, имеется ли среди них хотя бы одна пара равных между собой чисел. Формат входных данныx Входной файл содержит три целых числа через пробел. Формат выходных данныx Выведите 'YES' если это так, и 'NO' в противном случае.
Ответ(ы) на вопрос:
Гость
Задача 1 Program Zadanie1; var i,N:integer; A:array[1..4]of integer; Begin readln(n); A[1]:=round(int(N/1000)); A[2]:=round(int(N/100))-A[1]; A[3]:=round(int(N/10))-A[1]-A[2]; A[4]:=N-A[1]-A[2]-A[3]; if (A[1]:=A[4]) and (A[2]:=A[3]) and (A[3]:=A[2]) and (A[4]=A[1]) then writeln('полином'); end; Задача 2 Program Zadanie2; var i,N:integer; A:array[1..3]of integer; function Kub(a):integer;begin Kub:=a*a*a;end; Begin readln(n); A[1]:=round(int(N/1000)); A[2]:=round(int(N/100))-A[1]; A[3]:=N-A[1]-A[2]-A[3]; if N*N=kub(A[1])+kub(A[2])+kub(A[3]) then writeln('равенство'); end;
Не нашли ответ?
Похожие вопросы