Помогите решить задачу по информатике в паскале!Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере. Пробелы, знаки препинания, заглавные и строчные буквы важны!Пример: Ввод: 17...
Помогите решить задачу по информатике в паскале!
Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере. Пробелы, знаки препинания, заглавные и строчные буквы важны!
Пример:
Ввод: 179
Вывод: The next number for the number 179 is 180.
The previous number for the number 179 is 178.
Ответ(ы) на вопрос:
var
x: real;
begin
read(x);
writeln('The next number for the number ', x, ' is ', x + 1);
writeln('The previous number for the number ', x, ' is ', x - 1);
end.
var
y: real;
begin
read(y);
writeln(String.Format('The next number for the number {0} is {1}.', y, y + 1));
writeln(String.Format('The previous number for the number {0} is {1}.', y, y - 1));
end.
Не нашли ответ?
Похожие вопросы